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Limitation of 
Liability 

Patents 

Copyright 

The information in this manual is subject to change without 
notice and does not represent a commitment on the part of 
Sierra Wireless or its affiliates. SIERRA WIRELESS AND ITS 
AFFILIATES SPECIFICALLY DISCLAIM LIABILITY FOR 
ANY AND ALL DIRECT, INDIRECT, SPECIAL, GENERAL, 
INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR 
EXEMPLARY DAMAGES INCLUDING, BUT NOT LIMITED 
TO, LOSS OF PROFITS OR REVENUE OR ANTICIPATED 
PROFITS OR REVENUE ARISING OUT OF THE USE OR 
INABILITY TO USE ANY SIERRA WIRELESS PRODUCT, 
EVEN IF SIERRA WIRELESS AND/OR ITS AFFILIATES 
HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES OR THEY ARE FORESEEABLE OR FOR CLAIMS 
BY ANY THIRD PARTY. NOTWITHSTANDING THE 
FOREGOING, IN NO EVENT SHALL SIERRA WIRELESS 
AND/OR ITS AFFILIATES’ AGGREGATE LIABILITY 
ARISING UNDER OR IN CONNECTION WITH THE SIERRA 
WIRELESS PRODUCT, REGARDLESS OF THE NUMBER OF 
EVENTS, OCCURRENCES OR CLAIMS GIVING RISE TO 
LIABILITY, BE IN EXCESS OF THE PRICE PAID BY THE 
PURCHASER FOR THE SIERRA WIRELESS PRODUCT. 

Portions of this product may be covered by some or all of the 
following US patents: 
5,515,013 5,629,960 5,845,216 5,847,553 5,878,234 
5,890,057 5,929,815 6,169,884 6,191,741 6,199,168 
6,339,405 6,359,591 6,400,336 6,643,501 6,516,204 
6,561,851 6,653,979 6,697,030 6,785,830 6,845,249 
6,847,830 6,876,697 6,879,585 6,886,049 6,968,171 
6,985,757 D442,170 D459,303 

and other patents pending. 

This product includes 
technology licensed from: 

Licensed by QUALCOMM Incorporated under one or more of 
the following United States patents and/or their counterparts 
in other nations: 
4,901,307 5,056,109 5,101,501 5,109,390 5,228,054 
5,267,261 5,267,262 5,337,338 5,414,796 5,416,797 
5,490,165 5,504,773 5,506,865 5,511,073 5,535,239 
5,544,196 5,568,483 5,600,754 5,657,420 5,659,569 
5,710,784 5,778,338 

Manufactured or sold by Sierra Wireless or its licensees under 
one or more patents licensed from InterDigital Group. 

©2006 Sierra Wireless. All rights reserved. 
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Trademarks AirCard® and Heart of the Wireless Machine® are registered 
trademarks of Sierra Wireless. 

Sierra Wireless, the Sierra Wireless logo, the red wave design, 
the red-tipped antenna, and Watcher are trademarks of Sierra 
Wireless. 

Other trademarks are the property of the respective owners. 

All product specifications are subject to change without notice. 
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1: Introducing the AirCard 800 Series 
Wireless Network Cards 

• AirCard 800 Series 
wireless network cards 

• Your account and 
coverage area 

• AirCard modem 
software 

• Before you can begin 
using the AirCard 
modem 

• Package contents 

Caution: Do not insert your 
AirCard modem into your PC 
Card slot before installing the 
software. 

AirCard 800 Series wireless 
network cards 
The AirCard 800 Series 3G wireless network cards are modems 
for your PC that allow you to connect to the Internet, send and 
receive e-mail, connect to a corporate network/VPN, or view 
streaming video, without the need of a network cable or phone 
line. 

The AirCard modem fits into the standard (Type II) PC Card 
slot available on most notebook PCs. 

Supported operating systems 

The AirCard modems work in: 
•	 Notebook PCs running Windows XP, 2000, Me, NT 4.0, or 

98 SE. (See “Software and Driver Installation” on page 17 
for more details.) 

The AirCard modem as a network card 

The AirCard modem can be configured to provide the 
“always-on” data connection that an Ethernet card or other 
wired LAN card provides. That is, you can set options in 
Watcher™ (a program that comes with the AirCard modem) 
that causes the AirCard modem to establish a network 
connection whenever you insert it, assuming GSM, GPRS, 
EDGE, UMTS, or HSDPA service is available. (See “HSDPA, 
UMTS, EDGE, and GPRS service support” on page 8.) 
Otherwise, you can configure Watcher to connect only when 
you click the Connect button. 
4 Apr.06 7 
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The AirCard modem connection provides access to the 
Internet. Once the connection is established, you can open your 
browser and connect to any web site available on the Internet, 
or access other Internet services (such as e-mail). 

HSDPA, UMTS, EDGE, and GPRS service 
support 

GPRS, EDGE, UMTS, and HSDPA are add-on data services to 
GSM mobile phone networks. The maximum data speeds 
when connected on these services are: 
•	 GPRS (General Packet Radio Service)—56 kbps (kilobits 

per second) 
•	 EDGE (Enhanced Data GSM Environment)—216 kbps 
•	 UMTS (Universal Mobile Telecommunications System)— 

384 kbps 
•	 HSDPA (High Speed Download Packet Access)—up to 

1.8 Mbps (Megabits per second) on the downlink (receive) 
with 500 to 800 kbps typical 

GPRS and EDGE are 2G (second generation) data services. 
UMTS and HSDPA are 3G (third generation) data services. 

When establishing a connection, your AirCard modem uses 
the fastest available service. If, for example, you are using an 
AirCard modem in an area that has GPRS and EDGE service 
but not UMTS or HSDPA service, the AirCard modem 
connects using EDGE service. 

Once the connection is established, you have access to all 
Internet services. 

Frequency band support 

Every GSM network operates on one of these radio frequency 
bands, in providing 2G (GPRS or EDGE) service: 
•	 850 MHz band—(also called the cellular band) used by 

some North American service providers 
•	 900 MHz band—used by some European service 

providers 
•	 1800 MHz band—used by some European and Asian 

service providers 
•	 1900 MHz band—(also called the PCS band) used by 

many North American service providers 

Every network that offers 3G UMTS/HSDPA service does so on 
one of these bands: 
•	 WCDMA 850—used by North American service providers 
2130623 
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Note: If you purchased the 
AirCard modem from a GSM 
service provider, you may 
already have an account. 
Otherwise, your retailer should 
be able to provide you with the 
names of companies that 
provide this service. 

Note: The fee for service is 
usually higher when you are 
“roaming” (connected to a 
network other than the one 
belonging to your service 
provider). 

•	 WCDMA 1900—used by North American service 
providers 

•	 WCDMA 2100—used by European, Asian, and Australian 
service providers 

The AirCard 850 modem and AirCard 860 modem support all 
of the 2G bands. The AirCard 850 modem supports the 
WCDMA 2100 3G band (for use outside of North America). 
The AirCard 860 modem supports the WCDMA 850 and 
WCDMA 1900 bands (for North American use). 

Your account and coverage area 

Companies that operate GSM networks and provide access to 
those networks are called service providers. You must have an 
account with a GSM service provider that offers HSDPA or 
UMTS service to use the AirCard modem’s 3G capability. (The 
AirCard modem is backward compatible to 2G service.) 

When you obtain your account, you are given a SIM card, also 
called a “smart card” or “smart chip”. (Depending on how you 
purchased your AirCard modem, you may already have an 
account, and your SIM card may have been included in your 
package.) The SIM card contains account information and 
must be inserted in the AirCard modem anytime you use it. 

Before you can use the AirCard modem, you must install the 
AirCard modem software and ensure that your AirCard 
modem is configured to use your account. Instructions on 
completing these steps are provided in the chapters that 
follow.

 Once installed and configured, you can connect to the Internet 
with the AirCard modem in any area in which you can obtain 
GPRS, EDGE, UMTS, or HSDPA service. Your ability to obtain 
service depends on these factors: 

•	 Proximity to a GSM network—You must be within the 
coverage area of a GSM network in order to use the 
AirCard modem. 

•	 Service provider—If you are within the coverage area of a 
network that is not operated by your own service provider, 
you can only obtain service if there is a roaming agreement 
between your service provider and the network operator. 

•	 Account provisions—Your account may restrict your 
usage to certain networks or limit the amount of time you 
can use the network. 

•	 Frequency band—You cannot connect to networks 
operating in bands not supported by your AirCard 
 Apr.06 9 
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modem, regardless of roaming agreements or account 
provisions. 

Most service providers have coverage maps on their web sites. 

AirCard modem software 
The AirCard modem comes with this software (made by Sierra 
Wireless): 
•	 The Watcher program that you use to manage the AirCard 

modem and monitor your connections 
•	 The driver software that forms the interface between the 

network card and your Windows operating system 
•	 The Network Adapter Manager software that allows you 

to switch between the AirCard modem and other network 
cards 

Before you can begin using the 
AirCard modem 
Before you can use the AirCard modem for the first time you 
must: 
1.	 Install the AirCard modem software: Watcher, the 

Network Adapter Manager, and the AirCard modem 
driver. 

2.	 Attach the antenna, insert the SIM into the AirCard 
modem and insert the AirCard modem into your PC Card 
slot. (Do not insert the AirCard modem before installing 
the software.) 

3.	 Obtain a GSM account (if this wasn’t done when you 
purchased the AirCard modem). 

4.	 Configure the AirCard modem to use your account (unless 
it was pre-configured.) 

5.	 If your Internet browser is configured to use a dial-up 
modem, you may need to set it to use a network card. 

The next chapters guide you through this process. 

Package contents 
Your AirCard modem package contains the following: 
•	 AirCard modem 
•	 Antenna 
2130623 
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•	 Installation CD containing the AirCard modem software 
and this installation guide 

•	 Quick start guide 
 Apr.06 11 
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2: The SIM Card and Your Account

• Inserting a SIM card 

into your AirCard 
modem 

• Removing a SIM card 
• Attaching the antenna 

to your AirCard 
modem 

Note: Without a valid SIM card 
and a valid account, your 
AirCard modem will not work. 

Note: Keep a written record, in a 
secure place, of the account 
information that your service 
provider gives you. Instructions 
on creating a profile are in the 
section “Configuring Your 
Account” on page 25. 

You require a GSM account and a SIM (Subscriber Identity 
Module) card to use the AirCard modem. The SIM card is a 
small chip (about the size of a postage stamp) that you insert 
into the AirCard modem. The SIM contains account infor­
mation used by the network to validate your access. 

Depending on how you purchased your AirCard modem, you 
may already have an account. In this case, the SIM should be 
included in your package. Otherwise, your retailer should 
direct you to a local company that provides GSM service. 

To activate an account, the service provider needs from you: 
•	 Billing information (such as a credit card number) used to 

collect payment for your network usage 
•	 Possibly the IMEI (International Mobile Equipment 

Identity), depending on your service provider. This 
number, printed on the AirCard modem box and on the 
AirCard modem label, identifies your device (AirCard 
modem model) on the GSM network. 

Your AirCard modem must be configured to use your account. 
If purchased from a service provider, your AirCard modem 
may have been pre-configured. Otherwise, you must set up a 
profile in Watcher. Instructions on setting up a profile are 
described in Chapter 4. 

If you change GSM service providers (such as if you move to a 
new city), you will need a new SIM card from your new 
service provider. You will also need to set up a new profile. 

Inserting a SIM card into your 
AirCard modem 
To install your SIM card into the AirCard modem, follow these 
steps: 
1.	 If your SIM is attached to a card, detach it and remove any 

fragments of the card stuck to the SIM. 
2.	 Hold the AirCard modem with the label on top and the 

antenna closest to you. 
4 Apr.06 13 
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Note: To prevent the SIM from 
becoming jammed in the AirCard 
modem slot, ensure the edge of 
the SIM is smooth before 
inserting it. Do not attach labels 
to your SIM as this may also 
cause it to become jammed. 

3.	 Locate the thin SIM card slot on the left side of the AirCard 
modem PC Card’s antenna end. 

4.	 Orient the SIM card, as shown in the diagram on the 
bottom side of the AirCard modem. 

5.	 Insert the end of the SIM card into the slot, and gently 
push it until it is fully inserted. 

Figure 2-1: Inserting the SIM card Into the AirCard modem SIM card slot 

Once the SIM card is properly inserted, it should not 
extend beyond the end of the card. 

Removing a SIM card 
To remove the SIM card, you will need a narrow object, such 
as a pen or a straightened paper clip, to push into the eject 
hole. 
1.	 Place the AirCard modem on a smooth, hard surface such 

as a tabletop. 
2.	 Position your pen or paper-clip above the eject hole, which 

is on the top surface of the AirCard modem housing, just 
to the right of the SIM card slot. (See Figure 2-2.) 

3.	 Press down gently (without excessive force) on the eject 
hole. The SIM card should pop out of its slot. 
2130623 
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Figure 2-2: Ejecting the SIM card 

4. Gently pull the SIM card from the slot until it slides free. 

Attaching the antenna to your 
AirCard modem 
The antenna attaches to the gold-plated connector on the end 
of the AirCard modem. 

Figure 2-3: Attaching the antenna to the AirCard modem 
 Apr.06 15 
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3: Software and Driver Installation

• System requirements 
• Installation on 

Windows XP, 2000, 
and Me 

• Installation on 
Windows NT 

• Setting Internet 
Explorer to use the 
AirCard modem 

System requirements 
The AirCard modem is supported on: 
•	 Windows XP (Home and Professional versions) 
•	 Windows 2000 
•	 Windows Me 
•	 Windows NT 4.0 with Service Pack 6a and Networking 

installed 
•	 Windows 98 SE 

To install the AirCard modem, you require these system 
resources: 

Table 3-1: System resource requirements 

Card slots 1 Type II PCMCIA (PC Card) slot 

Disk drive CD-ROM 

I/O resources 1 IRQ, 40 bytes I/O space 

Memory 32 MB 
4 Apr.06 17 
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Note: Users of Windows 2000 
must be logged in with adminis
trative privileges. Users of 
Windows XP may require admin
istrative privileges. 

Note: The installer runs twice— 
once to install Watcher and once 
to install the Network Adapter 
Manager. 

Note: Do not forcefully insert the 
AirCard modem. This may 
damage connector pins. If you 
have more than one PC Card 
slot, you may obtain better signal 
strength using the top slot. 

Installation on Windows XP, 
2000, and Me 

Note: If you are running Windows 98 SE, Me, or 2000, Windows 
Installer Redistributable 2.0 must be installed. This is available on the 
Microsoft web site, www.microsoft.com. 

Note: You may require your Windows CD. Ensure you have the CD 
before proceeding. 

1.	 If the AirCard modem CD is not already in your CD-ROM 
drive, insert it. The CD should autostart and display a 
menu. 
If the CD does not autostart, select Start > Run and enter 
d:\setup.exe where d is the drive letter of your CD-ROM 
drive. 

2.	 From the CD start-up menu, select your language, then 
notebook installation, and then the link under notebook 
software installation to launch the installer. 

3.	 Use the Next and Back buttons to navigate through the 
installer. 

4.	 If the SIM is not already inserted in your AirCard modem, 
insert it. (See page 13.) If the antenna is not yet attached, 
attach it. (See page 15.) With the label facing up, insert the 
AirCard modem into your PC Card slot. 

Figure 3-1: Inserting the AirCard modem 
2130623 
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Note: The AirCard modem 
driver requires that Windows 
Networking is installed. Also 
the PC Card slots must be 
enabled. If you are not certain 
that networking is installed 
and the slots enabled, see the 
Windows NT user documen
tation for instructions. You 
must be logged in with admin
istrative privileges. 

Note: The installer runs twice— 
once to install Watcher and once 
to install the Network Adapter 
Manager. 

To close the CD start-up menu, click the exit option in the lower 
right corner of the window.

Watcher should launch automatically when the AirCard

modem is inserted. If your AirCard modem has not yet been 

configured to use your account, you are prompted to do so. 

See “Setting up a profile” on page 26.


Installation on Windows NT 

Note: You must re-install the Windows NT Service Pack after you 
install the AirCard modem driver. Ensure you have your Service Pack 
CD before you begin. (Version 6a is supported.) 

Note: Windows Installer Redistributable 2.0 must be installed. This is 
available on the Microsoft web site, www.microsoft.com. 

Note: The Performance Data Helper DLL, PDH.DLL, must be 
installed. You can download this from the Microsoft web site. 

Note: You may require your Windows CD. Ensure that you have the 
CD before proceeding. 

1.	 If the AirCard modem CD is not already in your CD-ROM 
drive, insert it. The CD should autostart and display a 
menu. 
If the CD does not autostart, select Start > Run and enter 
d:\setup.exe where d is the drive letter of your CD-ROM 
drive. 

2.	 From the CD start-up menu, select notebook installation and 
then the link under notebook software installation to launch 
the installer. 

3.	 Use the Next and Back buttons to navigate through the 
installer. 

When the software installation is complete, exit the startup 
menu by clicking exit in the lower right corner. 
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Note: Your PC must be off 
whenever you insert or eject the 
AirCard modem. 

Note: Do not forcefully insert the 
AirCard modem. This may 
damage connector pins. If you 
have more than one PC Card 
slot, you may obtain better signal 
strength using the top slot. 

Note: Depending on how 
Windows NT is configured, the 
prompts and windows described 
here may not appear in the 
precise order indicated. Use 
these instructions as a guideline. 

Inserting the AirCard modem 

1.	 Close all Windows programs and turn your PC off. 
2.	 If the SIM is not inserted in your AirCard modem, insert it. 

(See page 13.) If the antenna is not attached, attach it. (See 
page 15.)  With the label facing up, insert the AirCard 
modem into your PC Card slot: 

Figure 3-2: Inserting the AirCard modem 

3.	 Turn on your PC. 
4.	 Log on as Administrator. 

Installing the network card driver 

1.	 Open the Control Panel by selecting Start > Settings > 
Control Panel. 

2.	 Double-click the Network icon to open the Network 
window. 

3.	 Click the Adapters tab in the Network window. 
4.	 Click the Add... button to open the Select Network Adapter 

window. 
5.	 Click the Have Disk... button to open the Insert Disk 

window. 
2130623 
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Note: The AirCard modem will 
not function with the default 
settings for the I/O port, interrupt, 
and COM port if any of these 
resources are allocated to 
another network card or other 
device. If you are familiar with 
the Windows NT Diagnostics 
window, you can check to see if 
these resources are available. 
Otherwise, leave the default 
settings and, if the AirCard 
modem does not function 
following the driver installation, 
see the instructions on changing 
the interrupt on page 22. 

6.	 Enter the path to the drivers as follows (where c is the 
drive letter for your hard drive): 
· For the AirCard 850 modem: c:\Program Files\Sierra 

Wireless Inc\AirCard 800 Series\Drivers\WinNT-AC850 

· For the AirCard 860 modem: c:\Program Files\Sierra 
Wireless Inc\AirCard 800 Series\Drivers\WinNT-AC860 

Click OK to open the Select OEM Option window in which 
Sierra Wireless 3G Adapter is selected. 

7.	 Click OK. A window opens showing the settings for the 
I/O port (0x800), interrupt (10) and COM port (4). 

8.	 If you are aware that these resources are in use by another 
device (see the note in the margin), change the settings and 
click OK. Otherwise, click OK to use the default settings. 
Windows then copies the driver files. 

9.	 Click Close to close the Network window and open the 
Microsoft TCP/IP Properties window. 

10.	 Select Sierra Wireless 3G Adapter in the Adapter field and 
select Obtain an IP address from a DHCP Server radio button. 

11.	 Click Yes to confirm that DHCP is to be used. 
12.	 Click OK to close the TCP/IP Properties window. 
13.	 Click No if prompted to restart your PC. (You can install 

the modem driver before restarting your PC.) 

On completion of this step, the network card driver is installed 
and you can proceed to install the modem driver. Follow the 
instructions in the next section. 

Installing the modem driver 

1.	 In the Control Panel, double-click the Modems icon. If the 
Install New Modem wizard opens, skip to Step 3. 
Otherwise, proceed to Step 2. 

2.	 Click the Add button to open the Install New Modem 
wizard. 

3.	 Select Don’t detect my modem, I will select it from a list and click 
Next. 

4.	 Select the Have Disk button. 
5.	 Enter the path to the drivers as follows (where c is the 

drive letter for your hard drive): 
· For the AirCard 850 modem: c:\Program Files\Sierra 

Wireless Inc\AirCard 800 Series\Drivers\WinNT-AC850 

· For the AirCard 860 modem: c:\Program Files\Sierra 
Wireless Inc\AirCard 800 Series\Drivers\WinNT-AC860 

Click OK. 
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Note: You must restart your PC 
to complete the installation. 

6.	 Verify that Sierra Wireless AirCard 3G Modem is displayed 
and click Next. 

7.	 Select the Selected Ports radio button and select the same 
communications port used for the network card driver 
(COM 4 unless you changed it). Click Next. 

8.	 Click Finish. 
9.	 Click Close to close the Network Properties window. 

10.	 If you are prompted to restart your PC, click Yes. 
Otherwise restart your PC from the Start menu. 

11.	 When the PC restarts, re-install your Service Pack. 

On completion of this step, the modem driver is installed and 
you can proceed to configure the AirCard modem to use your 
account (if it was not preactivated). See “Configuring Your 
Account” on page 25“. 

Changing the interrupt 

If the message, “Communication Failed!…” occurs when you 
start Watcher, a possible reason is that you have assigned an 
interrupt to the AirCard modem that has also been assigned to 
another device. 

To change the interrupt assigned to the AirCard modem: 
1.	 Open the Control Panel by selecting Start > Settings > 

Control Panel. 
2.	 Double click the Network icon. 
3.	 Select the Adapters tab. 
4.	 Select Sierra Wireless 3G Adapter and click the Properties… 

button. 
5.	 Use the drop-down list to change the interrupt to another 

number and click OK. 
6.	 Close the Network window by clicking the Close button. 
7.	 Restart your PC. 
8.	 If the AirCard modem still does not function properly, 

repeat the procedure, selecting a different interrupt. 

Setting Internet Explorer to use 
the AirCard modem 
If you are using Internet Explorer as your browser, and it is set 
to connect to the Internet through a dial-up modem, you must 
set it to use a LAN (local area network) card. 
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To set Internet Explorer version 5 or 6 to use a LAN, follow 
these steps: 
1.	 In Internet Explorer, select Tools > Internet Options. 
2.	 Click the Connections tab. 
3.	 Click Setup to run the Internet Connection wizard. 
4.	 Select the option “I want to set up my Internet connection 

manually, or I want to connect through a local area network 
(LAN).” Click Next. 

5.	 Select “I connect through a local area network (LAN)”. Click 
Next. 

6.	 Ensure no check boxes are selected in the “Local area 
network Internet configuration” window and click Next. 

7.	 Select No when prompted to set up an Internet mail 
account and click Next. 

Click Finish to exit the wizard. 
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4: Configuring Your Account

• Setting up a profile Profiles contain account information used by the AirCard 

modem to establish connections. At least one profile must be 
set up on the AirCard modem before you can use it. The 
profile(s) may have been stored on the AirCard modem before 
you purchased it. Otherwise, your service provider should 
give you all the information you need to set up the profile(s) 
you require. 

Depending on your service provider, some or all of this infor­
mation must be entered into your profile: 
•	 User Name 
•	 Password 
•	 APN (Access Point Name) 
•	 IP (Internet Protocol) Address (if the address is not 

automatically assigned by the network) 
•	 Use of IP header compression 
•	 DNS (Domain Name Server) address or addresses 

Your service provider may give you only one APN in which 
case you require only one profile. Some service providers 
assign separate APNs for separate purposes. For example, 
some service providers supply one APN to use for Internet 
browsing and a different APN to use with a VPN. In this case 
you must set up multiple profiles. The AirCard modem allows 
for up to sixteen profiles. 

Most service providers have one or two standard profiles that 
all or most of their subscribers are expected to use. Most of 
these standard profiles have been pre-defined in Watcher, 
allowing you to select a standard profile, rather than creating it 
manually. 

One of your profiles must be set as the “default” profile. This is 
the one that is used if you select the Connect button without 
selecting a profile. The default profile is also used if you set the 
AirCard modem to autoconnect. If you are using the AirCard 
modem to access a network that requires you to provide a 
password each time you connect, you must set the connection 
mode for your profile to prompt for password (in which case 
you must connect manually). 
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Note: You cannot set up a 
profile before installing the 
software. (See page 17.) 

Setting up a profile 

To determine whether you have a profile: 
1.	 Insert the SIM into the AirCard modem if it is not already 

inserted. (See page 13.) 
2.	 Insert the AirCard modem into the PC Card slot if it is not 

already inserted. (See page 20.) 
3.	 If Watcher is not running, start Watcher by selecting 

Start > Programs > Sierra Wireless >3G Watcher > 3G Watcher 

or double-clicking the desktop shortcut. 


If Watcher detects that no profile has been set up, you are 

prompted, “Would you like to configure a profile now?” 

Select Yes.

If this prompt does not appear, your AirCard modem may 
have been preconfigured. You can verify that you have a 
profile by selecting Tools > Connections to access the 
AirCard modem tab of the Connections window, which 
lists all profiles. 

To create a profile: 

1.	 On the Connections window, Click the add button  and 
click WWAN profile. 

2.	 If you want to use a pre-defined profile, in the Profile Name 
field, select the profile from the drop-down list. Then skip 
to Step 5. 

3.	 Complete the fields in the Profile window by entering a 
Profile Name (any meaningful description of the profile, 
such as the name of your service provider) and User Name, 
Password, and/or APN, if applicable. 

4. Select whether you want to make connections automati­
cally or manually, or whether you are required to provide 
a password each time you make a connection: 
· If you select Autoconnect, a connection is established 

automatically whenever you insert the AirCard modem. 
· If you select Manual, you must select the Connect button 

on the main Watcher window to make a connection. 
·	 If you select Prompt for Password, you must select Connect 

and enter a password to make a connection. Use this 
option if you have an external device that provides a 
time-scheduled secure password for your corporate 
network. 

5.	 If you want to set Watcher to launch your Internet browser, 
VPN, or any other program automatically, or if your 
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service provider specified an IP address, or DNS 
address(es), select the Advanced folder. Otherwise, click OK 
and skip to Step 10. 

6.	 Select the Launch after connecting field, and from the drop-
down list, select which application, if any, you want 
Watcher to automatically launch when a connection is 
established with this profile: 
· None—No application is autolaunched. 
· Browser—Watcher autolaunches your default Internet 

browser. 
· MS VPN—Watcher autolaunches a Virtual Private 

Network (VPN) connection. 
· Application—Watcher autolaunches an installed VPN 

program, or any other program. 
7. Complete the appropriate field, depending on the option 

you chose in the Launch after connecting field: 
· If you selected Browser, in the URL field—type the URL 

for the web site you want to view on connection (such as 
www.sierrawireless.com). 

· If you selected Microsoft VPN—in the Microsoft VPN 
(PPTP) connection field, select the VPN connection from 
the drop-down list. 

·	 If you selected Application, in the Application field— 
enter the path to the program or use the browse button 

 to locate the .exe file for the software application you 
want to autolaunch. 

8.	 If your service provider has given you an IP address, in the 
Advanced folder, click TCP/IP. Select Static IP and enter the 
address in the field below. Otherwise select Dynamic IP. 
(This is the default because most networks use dynamic IP 
addressing.) Use the data compression or IP header 
compression fields if supported by your service provider. 

Note: The Use IP header compression field should NOT be used 
unless your service provider is using this compression. The AirCard 
modem cannot maintain a connection if this is enabled but not 
supported on the network. 

9.	 If you have a DNS address or addresses, click DNS Settings 
and enter the address(es). (In most cases, it is not necessary 
to enter a DNS address.) 

10.	 If you have more than one profile, select Profiles, and in the 
Default Profile field, choose the default profile from the 
drop-down list. (The “default” profile is the one used by 
the autoconnect feature and is used if you click Connect 
without selecting a profile.) 
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11. Click Apply to save the change without exiting the window, 
or, click OK to save the change and exit the window. 
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5: Care and Maintenance of Your 
Network Card 
• Stopping and ejecting 

the AirCard modem 

Note: Do not insert the AirCard 
modem before installing the 
software. See “Software and 
Driver Installation” on page 17. 

Windows PC Card icons

98 Me/2000 XP


You can ensure reliable operation and long life of your 
AirCard modem by adhering to these guidelines in storage 
and use: 
•	 Do not apply adhesive labels to the AirCard modem or 

SIM. This may cause the AirCard modem or SIM to 
become jammed inside the slot, or prevent it from being 
inserted properly. 

•	 When not installed in your computer, store the AirCard 
modem and SIM in a safe place. 

•	 Protect the card from liquids, dust, and excessive heat (see 
“Environmental specifications” on page 39 for details). 

•	 The AirCard modem should fit easily into your computer’s 
PC Card slot. Forcing the AirCard modem into the slot 
may damage the connector pins. 

•	 Optimal signal strength is usually obtained when the 
antenna is pointing straight up. The antenna should bend 
easily at the hinge. Do not forcefully bend the antenna. 

Figure 5-1: Proper positioning of the AirCard modem antenna 

When you insert the AirCard modem in a notebook PC, the 
following should happen: 
•	 The PC beeps (unless the effect is disabled). 
•	 The PC Card icon appears in the status area (usually 

located in the lower right corner of the screen) unless the 
feature is disabled. 

•	 The Network Adapter Manager icon for the AirCard 
modem also appears in the status area. 

•	 Watcher launches (unless the autolaunch option is 
disabled). 
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Stopping and ejecting the 
AirCard modem 
To remove the AirCard modem: 
1.	 Close Watcher if it is open. 
2.	 Click the PC Card icon in the status area to display the 

option to stop the card. 
3.	 Click “Stop Sierra Wireless AirCard 3G Adapter Parent” 

(Windows 98, 2000, or Me) or “Safely remove Sierra 
Wireless AirCard 3G Adapter Parent” (Windows XP). 

4.	 If a dialog box appears notifying you that it is safe to 
remove the card, click OK. 

5.	 Push the PC Card eject button on your computer to eject 
the card. 

Figure 5-2: Ejecting the AirCard modem from its slot 

6. Grasp the AirCard modem and remove it from the slot. 
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6: Watcher Basics

• Launching Watcher 
• The Watcher window 
• Icons and indicators 

on the main Watcher 
window 

• View options 
• Status icons 
• Turning the radio on 

and off 
• Frequency band and 

network selection 

Note: It takes up to 20 seconds 
for Watcher to become fully 
functional after launch. 

Watcher is the program you use to manage and monitor your 
AirCard modem connections. Watcher allows you to: 
•	 Create an account profile. (This is explained under “The 

SIM Card and Your Account” on page 13.) 
•	 Determine signal strength, roaming status, GPRS/EDGE/ 

UMTS/HSDPA availability, and other network connection 
parameters 

•	 Monitor the status of the AirCard modem and GSM 
service 

•	 Initiate data connections 
•	 Enable or disable SIM security that prevents others from 

using your SIM card if it is lost or stolen 
•	 Set options related to notifications and the Watcher 

window 

If you set your account profile to autoconnect (see page 26), 
you do not need to run Watcher when you use the AirCard 
modem, but Watcher does provide useful status information. 

Launching Watcher 
Unless the feature has been disabled, Watcher launches 
automatically anytime you insert the AirCard modem. You can 
also launch Watcher by: 

•	 Double-clicking the desktop shortcut, or 
•	 Selecting Start > Programs > Sierra Wireless > 3G Watcher > 

3G Watcher 

Depending on how your profile is configured, your browser, 
VPN, or other program may launch automatically anytime you 
launch Watcher. See page 27. 
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Note: To get help in Watcher, 
select Help > Help Topics. You 
can also display help by pressing 
<F1> in most windows. 

The Watcher window 

Compact 
view Close 

Roaming Minimize 

GPRS/EDGE/UMTS/

HSDPA coverage


Signal strength 

Indicator area 

Profile drop-down list 

Figure 6-1: The Watcher window. 

Icons and indicators on the 
main Watcher window 
These icons are used on the main Watcher window: 

Table 6-1: Icons and indicators in Watcher 

Device status. If an icon of the AirCard modem 
with an “X” is displayed, Watcher is unable to 
detect the AirCard modem. This indicates that 
the AirCard modem is not fully inserted into the 
PC Card slot or the device is powered down. 

You may be able to resolve this problem by 
restarting Watcher, powering up the AirCard 
modem, stopping, ejecting, and reinserting the 
AirCard modem, or restarting your PC. 

Signal strength and service status. The 
number of bars beside the antenna increases as 
signal strength increases, to a maximum of five 
bars. The ToolTip that displays when you 
position the mouse pointer over this indicator 
shows the numeric value of the RSSI (Received 
Signal Strength Indication in dBm). 

An antenna with a line through it indicates no 
service is available (Not in Service). You are 
outside of the coverage area or have insufficient 
signal strength to maintain a GSM data 
connection. 
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Table 6-1: Icons and indicators in Watcher 

Coverage. The icon shows the fastest service 
available: 
• GPRS icon—GPRS is the fastest service 

available in your current coverage area. 

• EDGE icon—EDGE is the fastest service 
available in your current coverage area. 
(supported on EDGE AirCard modems) 

• 3G—UMTS is the fastest service available 
in your current coverage area. (supported 
on UMTS AirCard modems) 

• HS—HSDPA is the fastest service available 
in your current coverage area. (supported 
on HSDPA AirCard modems) 

When only the letters are displayed, (for example 
), you are within the coverage area, but have 

not yet acquired the service. 

When the indicator has an outline ( ), you 
have acquired service and are able to establish a 
data connection. 

When the indicator is filled ( ), you have a 
data connection on the wireless service. 

Roaming. You are connected to a network 
other than your local service provider's. There 
may be a surcharge for roaming service. (This 
service may not be available.) 

New SMS message. Click the icon to open the 
SMS Express window and read your messages. 
When your SIM becomes full, this icon flashes 
and turns red. (Supported only on selected 
devices.) 

Headset. If your AirCard modem is voice-
enabled and the headset is supported, this 
indicator is displayed when a headset is 
attached. 

Missed call. If your AirCard modem is voice-
enabled, this indicator is displayed when you fail 
to answer an incoming call. Click the icon to 
open the call history and view the numbers of the 
calls you missed (assuming you have caller ID 
service with your account). 

Voice mail. If your AirCard modem is voice-
enabled, this indicator is displayed when you 
have a new voice message. Click the icon to 
access your voice mail box (assuming you have 
voice mail service with your account). 
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Compact View 
Minimize  Close 

Table 6-1: Icons and indicators in Watcher 

Call forwarding. If your AirCard modem is 
voice-enabled, this indicator is displayed when 
call forwarding is in use. (This appears only 
when all calls are forwarded.) 

TTY. If your AirCard modem is voice-enabled, 
this indicator is displayed if TTY support is 
enabled. (TTY or TeleTYpe devices allow speech 
and hearing impaired people to use a phone). 
(Depending on your AirCard modem 
configuration, you may not have this indicator.) 

Data transmission. When the modem is 
connected to the network, the main Watcher 
window shows you the amount of data received 
and sent. 

View options 
You have these options concerning the Watcher window: 
•	 You can enable/disable always on top from the View 

menu. When enabled, the Watcher window always 
appears in front of other application windows. 

•	 You can switch between the full Watcher window and the 
compact window from the View menu or by using the 
Compact View button: 

•	 You can use the Minimize button to close the Watcher 
window but leave the program running. 

Status icons 
These icons appear in the system tray (usually in the lower 
right corner of your screen). 

Watcher cannot detect the AirCard modem. Ensure 
that the AirCard modem is powered on. 

You do not have an active high-speed connection. 
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You have an active high-speed connection. 

You have new (unread) SMS messages. 

Turning the radio on and off 
This option allows you to conserve your computer’s battery by 
turning off the AirCard modem radio transmitter/receiver 
when you are not using it. 

To turn off the radio: 
1.	 Select Tools > Turn Radio Off. 

When the radio is turned off, the menu option switches to Turn 
Radio On and the message, “Radio is off” is displayed in the 
Watcher window. 

To turn on the radio: 
1.	 Select Tools > Turn Radio On. 

Frequency band and network 
selection 
Watcher has two options that affect your ability to obtain 
GPRS, EDGE, UMTS, or HSDPA service in any given area. You 
can select: 
•	 The frequency band you want to use 
•	 The network you want to use, if you are within the 

coverage area of more than one network 

Frequency band selection 

Every GSM network operates on one set of frequency bands. 
(See “Frequency band selection” on page 35.) The AirCard 
modem is designed to change frequency bands automatically 
as required to obtain network service. You can also change 
frequency bands manually from the Network tab of the 
Options window (Tools > Options > Network). 

Note: Unless your service provider specifies otherwise, it is recom
mended that you use the Auto setting. 
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Network selection 

Depending on your location, you may be within the coverage 
area of several networks. Your ability to obtain service on each 
network is dependent on your account. 

Your options for network selection are: 
•	 Automatic—The AirCard modem automatically selects a 

network based on your account and network availability. 
•	 Manual—The AirCard modem scans the area and displays 

a list of detected GSM networks. You can then choose from 
a list of available networks. 

If you select a network on which you cannot obtain service, the 
message, “Failed to register with network” appears. You 
should then choose a different network. 

This option is set on the Network tab of the Options window 
(Tools > Options > Network). 
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7: Technical Specifications

• LED operation 
• Radio frequency and 

electrical 
specifications 

• Environmental 
specifications 

• Sending GSM 
commands to the 
network 

This chapter describes the operation of the LED and provides 
technical data for the AirCard modem. 

LED operation 
The AirCard modem has a single LED (Light Emitting Diode) 
located on the antenna end of the card beneath the SIM slot. 
The color (red, green or amber) and state (off, on solid, or 
blinking) of the LED indicate the connection status as follows: 

Table 7-1: LED operation 

LED state How to interpret 

Solid 
amber1 

The AirCard modem is powering up, or a 
firmware download is in progress. 

Blinking
amber 

The AirCard modem is scanning for service. 

Blinking 
green 

The AirCard modem is in service and registered 
on the network. 

Blinking red There is a hardware problem. 

Off The AirCard modem is powered down. 

1.	 The LED is red/green. The amber color occurs when both red and 
green are lit. 

Radio frequency and electrical 
specifications 
Table 7-2: Radio frequency & electrical 
specifications 

Compliance GSM Release 5 

Multi-slot class Class 10, HSDPA CAT 12 
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Table 7-2: Radio frequency & electrical 
specifications (cont.) 

Transmit PCS: 
1850 to 1910 MHz 
DCS1800: 
1710 to 1785 MHz 
EGSM900: 
880 to 915 MHz 
GSM850: 
824 to 849 MHz 
WCDMA2100: (AirCard 850 modem only) 
1920 to 1980 MHz 
WCDMA850: (AirCard 860 modem only) 
824 to 849 MHz 
WCDMA1900: (AirCard 860 modem only) 
1850 to 1910 MHz 

Receive PCS: 
1930 to 1990 MHz 
DDCS1800: 
1805 to 1880 MHz 
EGSM900: 
925 to 960 MHz 
GSM850: 
869 to 894 MHz 
WCDMA2100: (AirCard 850 modem only) 
2110 to 2170 MHz 
WCDMA850: (AirCard 860 modem only) 
869 to 894 MHz 
WCDMA1900: (AirCard 860 modem only) 
1930 to 1990 MHz 

Channel spacing 200 kHz (GSM) 
5 MHz (WCDMA) 

Channel raster 200 kHz 

Frequency
stability 

0.1 ppm 
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Environmental specifications 
Table 7-3: Environmental specifications 

Operating 
temperature 

-20 to +65 °C (ambient, outside PCMCIA 
enclosure) 

Storage 
temperature 

-30 to +85 °C 

Humidity 95%, non-condensing 

Vibration 15 g peak 10 to 2000 Hz (non-operating) 

Sending GSM commands to the 
network 
GSM commands are used to: 
•	 Access network services 
•	 Display network and device parameters 
•	 Provide account status information (for example, indicate 

whether a subscribed service is available to you) 

If your service provider asks you to enter a specific command: 
1.	 Using your keyboard, type the command. 

If the command was valid and accepted by the network, 
the results are displayed in the Watcher window. Other­
wise, the message “Invalid GSM Command” is displayed. 

For example, enter *#06#. This command displays the IMEI1. 

You can send GSM commands even when a data transfer is in 
progress. 

1.	  IMEI—International Mobile Equipment Identity—a 
number that uniquely identifies your device (AirCard 
modem) on the GSM network 
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8: Regulatory and Safety 

Information

• Important notice 
• EU regulatory 

conformity 
Important notice 
Because of the nature of wireless communications, trans­
mission and reception of data can never be guaranteed. Data 
may be delayed, corrupted (that is, have errors) or be totally 
lost. Although significant delays or losses of data are rare 
when wireless devices such as the Sierra Wireless network 
card are used in a normal manner with a well-constructed 
network, the Sierra Wireless network card should not be used 
in situations where failure to transmit or receive data could 
result in damage of any kind to the user or any other party, 
including but not limited to personal injury, death, or loss of 
property. Sierra Wireless and its affiliates accept no responsi­
bility for damages of any kind resulting from delays or errors 
in data transmitted or received using the Sierra Wireless 
network card, or for failure of the Sierra Wireless network card 
to transmit or receive such data. 

Safety and hazards 

Do not operate your AirCard modem: 
•	 In areas where blasting is in progress 
•	 Where explosive atmospheres may be present including 

refuelling points, fuel depots, and chemical plants 
•	 Near medical equipment 
•	 Near life support equipment, or any equipment which 

may be susceptible to any form of radio interference. In 
such areas, the AirCard modem MUST BE POWERED 
OFF. Otherwise, the AirCard modem can transmit signals 
that could interfere with this equipment. 

In an aircraft, the AirCard modem MUST BE POWERED OFF. 
Otherwise, the AirCard modem can transmit signals that could 
interfere with various onboard systems and may be dangerous 
to the operation of the aircraft or disrupt the cellular network. 
Use of a cellular phone in an aircraft is illegal in some jurisdi­
cations. Failure to observe this instruction may lead to 
suspension or denial of cellular telephone services to the 
offender, or legal action or both. 

Some airlines may permit the use of cellular phones while the 
aircraft is on the ground and the door is open. The AirCard 
modem may be used normally at this time. 
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 EU regulatory conformity 
Sierra Wireless hereby declares that the AirCard 850 modem is 
in conformity to all the essential requirements of Directive 
1999/5/EC: 

The Declaration of Conformity made under Directive 1999/5/ 
EC is available for viewing at the following location in the EU 
community: 

Sierra Wireless (UK), Limited 
Lakeside House 
1 Furzeground Way, Stockley Park East 
Uxbridge, Middlesex 
UB11 1BD 
England 
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